Intermittent Outages

Incident Report for OpenGov

Resolved

This incident has been resolved.
Posted Jun 22, 2026 - 08:17 PDT

Update

We are continuing to investigate this issue.
Posted Jun 22, 2026 - 07:32 PDT

Update

We are continuing to investigate this issue.
Posted Jun 22, 2026 - 07:27 PDT

Update

We are continuing to investigate this issue.
Posted Jun 22, 2026 - 07:26 PDT

Update

We are continuing to investigate this issue.
Posted Jun 22, 2026 - 07:16 PDT

Investigating

We are aware that some users are experiencing errors when attempting to access our products. Our engineering team is currently investigating the root cause and working toward a resolution. We will provide updates as the situation develops.
Posted Jun 22, 2026 - 07:01 PDT
This incident affected: Budgeting & Performance, Reporting & Transparency, Financials, Procurement, Tax & Revenue (formerly iGovServices), Permitting & Licensing, Asset Management (formerly Cartegraph), Open Data, Community Feedback (formerly Open Town Hall), Utility Billing, Platform (FTP, Integration Services, OpenGov Platform), and Government App Builder (#311, Government App Builder, Grants Management).