Open Data: Open Data Portals are Inaccessible

Incident Report for OpenGov

Resolved

This incident has been resolved.
Posted May 21, 2025 - 08:39 PDT

Investigating

Server 503. All portals unavailable
Posted May 21, 2025 - 07:24 PDT
This incident affected: Open Data.