Payment steps not Completing

Incident Report for OpenGov

Resolved

This incident has been resolved. All payment steps that were paid in full during this time have been updated to a completed status.
Posted Sep 26, 2025 - 10:08 PDT

Investigating

Our engineering team is aware and investigating, payment steps not completing. The payments are being recorded in the history, and e-check/Credit card payments are being processed in Stripe.

In the meantime, if you need the step to proceed immediately, Admins can click the Complete and Proceed button in the bottom right.
Posted Sep 26, 2025 - 09:04 PDT
This incident affected: Permitting & Licensing.