While the Major Outage reported by Cloudflare is reported as resolved, there are underlying connecting applications that are still contributing to software and application access. We are continuing to monitor.
Posted Nov 18, 2025 - 10:55 PST
Monitoring
Cloudflare has noted they are continuing to investigate the outage. We recognize aspects of access in relation to OpenGov software applications may still be impacted.
Posted Nov 18, 2025 - 07:26 PST
Investigating
Hello, We are writing to advise that OpenGov is actively tracking the Cloudflare global outage. We recognize that some aspects of software applications may be impacted, inaccessible or running slowly. We will keep our customers advised when services are restored.
EAM/Cartegraph customers might experience failures when downloading or updating the mobile app until this is resolved.
Posted Nov 18, 2025 - 05:47 PST
This incident affected: Budgeting & Planning, Reporting & Transparency, Financials, Procurement, Tax & Revenue (formerly iGovServices), Permitting & Licensing, Asset Management (formerly Cartegraph), Open Data, Community Feedback (formerly Open Town Hall), OpenGov Help Center and Platform (FTP, Integration Services, OpenGov Platform).