Old Contracts Landing Page export columns misalignment

Incident Report for OpenGov

Update

We are continuing to investigate this issue.
Posted Feb 26, 2026 - 08:35 PST

Investigating

We are currently investigating this issue.
Posted Feb 26, 2026 - 08:34 PST
This incident affects: Procurement.