Help Center and Technical Support Outage

Incident Report for OpenGov

Identified

The third-party service provider has identified the cause and is rolling out a fix region by region. Most services are recovering, and we are seeing improvement in the OpenGov Help Center and our support contact channels.

Service may still be intermittent. You may encounter errors, delays, or failures when submitting or viewing support cases until the rollout completes. There is no confirmed resolution time from the provider at this stage.

Your OpenGov applications remain unaffected — this is limited to support channels only.
Posted Sep 16, 2026 - 05:56 PDT

Investigating

We are experiencing an outage affecting the OpenGov Help Center and our technical support contact channels, caused by an issue with a third-party service provider. Our team is actively investigating.

Your OpenGov applications are not impacted — this is limited to support channels only.

During this outage, you may be unable to submit or view support cases. If you have an urgent, production-impacting issue, please contact your Customer Success Manager directly.
Posted Sep 16, 2026 - 04:38 PDT
This incident affects: OpenGov Help Center.