Performance Degradation - Including "Pay Now" button not available.

Incident Report for OpenGov

Resolved

This incident has been resolved.
Posted Apr 15, 2026 - 15:22 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 15, 2026 - 08:23 PDT

Update

We are continuing to investigate this issue.
Posted Apr 15, 2026 - 07:31 PDT

Investigating

We are currently investigating system performance situation that may be impacting multiple areas of the platform.

Users may experience issues such as:

Site-wide slowness
Slow search performance
Inspection types not loading
Inspection maps not loading
"Pay Now" button appearing greyed out

Please note that this is not a complete list, and other functionality may also be affected. We are actively working to identify and resolve the issue.
Posted Apr 15, 2026 - 06:05 PDT
This incident affected: Permitting & Licensing.