Cloudflare Network Performance Impact

Incident Report for OpenGov

Resolved

This incident has been resolved.
Posted Dec 21, 2025 - 14:58 PST

Investigating

Cloudflare is currently experiencing intermittent degraded network performance. At this time, there has been no impact to our sites or services.

There is a potential for slowness or degraded performance within our systems.

We are actively monitoring the situation and will provide updates if conditions change.
Posted Dec 19, 2025 - 07:53 PST
This incident affected: Budgeting & Planning, Reporting & Transparency, Financials, Procurement, Tax & Revenue (formerly iGovServices), Permitting & Licensing, Asset Management (formerly Cartegraph), Open Data, Community Feedback (formerly Open Town Hall), OpenGov Help Center and Platform (FTP, Integration Services, OpenGov Platform).