AWS Outage, impacting connectivity and service

Incident Report for OpenGov

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 04:06 PDT

Update

All issues have been resolved
Posted Oct 21, 2025 - 04:05 PDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 14:19 PDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 14:15 PDT

Update

Users are unable to access Budgets and Reports
Posted Oct 20, 2025 - 14:11 PDT

Monitoring

AWS Reported a Global Internet Outage in the early morning hours of Monday 10.20. AWS has stated they are applying mitigation steps for recovery. OpenGov will continue to monitor restoration of services.
Posted Oct 20, 2025 - 09:55 PDT
This incident affected: Budgeting & Planning and Reporting & Transparency.