Permitting & Licensing: Site slowness

Incident Report for OpenGov

Resolved

This incident has been resolved.
Posted Dec 15, 2025 - 09:49 PST

Investigating

We are currently experiencing site slowness, we are investigating.
Posted Dec 15, 2025 - 09:07 PST
This incident affected: Permitting & Licensing.