Permitting & Licensing is unable to take Credit Card Payments

Incident Report for OpenGov

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 07:21 PST

Monitoring

A fix has been implemented and we are monitoring.
Posted Nov 24, 2025 - 07:08 PST

Investigating

We are currently investigating this issue. Other forms of payment are accepted at this time.
Posted Nov 24, 2025 - 06:03 PST
This incident affected: Permitting & Licensing.