Permitting & Licensing: Site Latency

Incident Report for OpenGov

Resolved

This incident has been resolved.
Posted May 20, 2026 - 10:09 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 20, 2026 - 09:22 PDT

Investigating

We are currently experience site latency that may result in slower loading time and reports not appearing.
Posted May 20, 2026 - 09:11 PDT
This incident affected: Permitting & Licensing.