Product Access - Server Error

Incident Report for OpenGov

Resolved

This incident has been resolved.
Posted Jun 11, 2026 - 13:28 PDT

Investigating

We have internally escalated the inability to log into the OpenGov products. Our Engineering teams are actively investigating this.
Posted Jun 11, 2026 - 13:09 PDT
This incident affected: Budgeting & Performance, Reporting & Transparency, Financials, Procurement, Tax & Revenue (formerly iGovServices), Permitting & Licensing, Asset Management (formerly Cartegraph), Open Data, Community Feedback (formerly Open Town Hall), Utility Billing and Platform (Integration Services, OpenGov Platform).