Permitting and Licensing: Forms not Loading on Record Page

Incident Report for OpenGov

Resolved

OpenGov is aware of a situation that impacted forms loading for some customers. The situation has been resolved, and we are continuing to monitor system performance while implementing additional safeguards to prevent recurrence.
Posted Feb 05, 2026 - 12:04 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 05, 2026 - 09:17 PST

Investigating

We are currently investigating this issue.
Posted Feb 05, 2026 - 07:48 PST
This incident affected: Permitting & Licensing.