GIS performance issues causing login slowness

Incident Report for OpenGov

Resolved

ArcGIS is reporting that this incident has been resolved.

For more information, please visit their site: https://status.arcgis.com/
Posted Jun 26, 2025 - 11:04 PDT

Update

GIS has reported a performance issue which may affect logging in to OpenGov.

Please check the GIS site for updates here: https://status.arcgis.com/
Posted Jun 26, 2025 - 07:40 PDT

Investigating

We are currently investigating this issue.
Posted Jun 26, 2025 - 07:35 PDT
This incident affected: Asset Management (formerly Cartegraph).