Financials Navigation Modules Missing for All Users; Error on Page Navigation

Incident Report for OpenGov

Resolved

This incident has been resolved.
Posted Jun 01, 2026 - 07:37 PDT

Investigating

OpenGov Engineering is currently investigating customers reporting their inability to see any Financials modules in the navigation bar. Upon navigating to any page within the application, a persistent red error banner is seen, reading "We are sorry, but there was an error processing your request".
Posted Jun 01, 2026 - 06:42 PDT
This incident affected: Financials.