Tax & Revenue: UI Field Locking, unable to edit fields

Incident Report for OpenGov

Resolved

This incident has been resolved.
Posted Mar 16, 2026 - 14:43 PDT

Update

Update: The fix to this experience is currently in QA for Testing and is scheduled to deploy at 430 pm CST. Once the fix is deployed to our customer environments, users will be required to log out and back in for the update to take affect.
Posted Mar 16, 2026 - 13:37 PDT

Update

Our Engineering Team has identified the cause and is working to correct the system. A release is being planned for today to update the system and restore functionality.
Posted Mar 16, 2026 - 11:54 PDT

Identified

Our team has identified the cause of the issue affecting Standard Filing line items and View Current Charges pages and is actively working on a fix.
Posted Mar 16, 2026 - 10:35 PDT

Investigating

We are currently investigating this issue.
Posted Mar 16, 2026 - 09:51 PDT
This incident affected: Tax & Revenue (formerly iGovServices).