Procurement: Insights module dashboards fail to load

Incident Report for OpenGov

Resolved

This incident has been resolved.
Posted Feb 23, 2026 - 09:34 PST

Update

We are continuing to monitor for any further issues.
Posted Feb 23, 2026 - 08:45 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 23, 2026 - 08:45 PST

Investigating

We are currently investigating this situation. The five affected charts are:
Solicitations
Vendors Notified
Vendors Notified per Solicitation
Avg Responses by Department
Avg Responses by Year

This is in regards to a Public Preview feature, and may not impact all users
Posted Feb 23, 2026 - 06:25 PST
This incident affected: Procurement.