Resident Payment Portal - Not allowing residents to make payments

Incident Report for OpenGov

Resolved

This incident has been resolved.
Posted Aug 11, 2025 - 11:28 PDT

Update

The concern relating to residents not having access to the payment portal has been resolved as of 12:00 pm 8/11/2025
Posted Aug 11, 2025 - 11:24 PDT

Investigating

Currently, we recognize the resident payment portal is preventing residents from successfully logging into their accounts and submitting payments for services. This situation is occurring consistently for all users attempting to access the payment portal. Our engineering team is actively investigating this concern and working to resolve it.
Posted Aug 11, 2025 - 09:05 PDT
This incident affected: Financials.