Tax & Revenue | Manual Cashier Payments Routing to WEB Balance Session Instead of Selected Session

Incident Report for OpenGov

Update

Our engineering team has prepared a fix and is targeting a release for today at 11:30 AM PST.

During that window you may experience a brief service disruption. We recommend pausing cashiering activity around that time and resuming once the release is confirmed complete.
Posted Jul 31, 2026 - 10:42 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 31, 2026 - 10:30 PDT

Investigating

We are currently investigating this issue.
Posted Jul 31, 2026 - 09:14 PDT
This incident affects: Tax & Revenue (formerly iGovServices).