Dashboards are not appearing for Customer

Incident Report for OpenGov

Resolved

This incident has been resolved.
Posted Jan 17, 2025 - 09:26 PST

Investigating

Dashboards are currently not appearing for customer. Our Engineering team is working to put in release to fix this.
Posted Jan 17, 2025 - 08:27 PST
This incident affected: Budgeting & Planning.